Get in touch
Back
Maintenance

Maintenance operation

Completed 26 Apr at 03:52pm CEST.

API Developer Organizer - authentication Play - authentication Play Widgets
Completed

Maintenance completed

Posted 26 Apr at 03:52pm CEST.
Started

Toornament is undergoing a major maintenance operation that require most of its services to be shutdown for about one hour.

Posted 26 Apr at 02:30pm CEST.