Get in touch
Back
Maintenance

Update of Play and product websites

Completed 18 Feb at 04:30pm CET.

Play - authentication Play Presentation site
Completed

Maintenance completed

Posted 18 Feb at 04:30pm CET.
Started

Release of the new Play and presentation websites.

Posted 18 Feb at 03:00pm CET.